Docker Community Forums

Share and learn in the Docker community.

Installing ghostscript within Windows container failed

I am using below dockerfile content to install ghostscript within my windows container

FROM mcr.microsoft.com/windows/servercore:ltsc2019

ADD https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs952/gs952w64.exe . 

RUN C:\gs952w64.exe /S /NCRC

CMD ["cmd.exe"]

But this is failing with following error:

The command ‘cmd /S /C C:\tmp\gs952w64.exe /S /NCRC’ returned a
non-zero code: 3221225785

I am able to do silent installation of ghostscript with this command in my local machine: C:\gs952w64.exe /S /NCRC
but not sure why it is failing in container.

I tried shared solution from here: Installing Ghostscript in Docker Windows image returned a non-zero code: 1 - Stack Overflow
but I got same error here as well.

Chocolatey installed 2/3 packages. 1 packages failed. See the log for
details (C:\ProgramData\chocolatey\logs\chocolatey.log).

Failures

  • ghostscript.app (exited -1073741511) - Error while running ‘C:\ProgramData\chocolatey\lib\Ghostscript.app\tools\ChocolateyInstall.ps1’.
    See log for details. The command ‘cmd /S /C choco install --yes
    ghostscript --version=9.52 ;’ returned a non-zero code: 3221225785

Can anyone help me on this?