Docker Community Forums

Share and learn in the Docker community.

Issue with Automated Build - ERROR: Error when trying to create deploy key

build
(Analogic) #21

@continuon Yes. At second attempt though, I don’t know if it needs some time to process or if there is cache, but its working.

(phil) #22

Thank you for clarifying. Just a bit confused - did you add the custom created public key to the Access Key for the repo and this key’s private key to the SSH_PRIVATE environment variable?

1 Like
(Oskar Svärd) #23

This really needs a hotfix asap :wink:

(phil) #24

I’m still not sure on who’s side the problem is coming from

(Andreamercieca) #25

Unfortunately since the logs are so… non-existent(?)… we have very little chance of debugging this without some insight from docker staff.

(Oskar Svärd) #26

Stopped working the day when docker deprecated managed clusters.

(Willseward) #27

I finally got an error in the build logs. Same story. I’ll try adding a customer key as a work-around, but this should be fixed.

Building in Docker Cloud's infrastructure...
Cloning into '.'...
Warning: Permanently added the RSA host key for IP address '104.192.143.1' to the list of known hosts.
Permission denied (publickey).
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.
please ensure the correct public key is added to the list of trusted keys for this repository (128)
(phil) #28

Welcome to the club - did the custom key work for you more than once? You can toggle it in your docker cloud settings to mail you on failed builds which gives you an error log too just as a FYI :slight_smile:

Also, how did you incorporate the custom key - did you add the private key to the build env and the public key to the repo?

Just odd that there isn’t more people complaining on Stack Overflow or here…which makes me think it might be that their infrastructure is not handling the load evenly

1 Like
(Willseward) #29

It’s worked at least once. I’ll have more info when the next build runs.

Note that the SSH_PRIVATE value must be the PEM-encoded private key, line-breaks and all.

(Oskar Svärd) #30

Any updates on the issue? Docker staff?

(Oskar Svärd) #31

Anyone? Only me that cant solve it?

(Itsthejb) #32

Had the same problem. Tried to completely remove the connection on both ends and re-add, but now can’t edit the build to add the connection. URL redirects to ./builds/edit, but nothing happens

(Patiponp202) #33

nice post thank you
ufabet
ufabet