Docker Community Forums

Share and learn in the Docker community.

Issue with nordvpn


(Paul Petit) #1

Hello,
I’m new Docker so I will maybe ask some stupid questions.

I’m trying to build a container using the NordVpn Linux client.

Here is my docker file.

FROM ubuntu:18.04

WORKDIR /app
COPY . /app

RUN apt-get update
RUN apt-get install --reinstall ca-certificates -y
RUN apt-get install ./nordvpn-release_1.0.0_all.deb -y
RUN apt-get update
RUN apt-get install nordvpn -y

CMD service nordvpn start && bash

I build it with

 kiyauden@kiyauden-pc:~/Docker/SeedBox$ docker build -t seedbox .`

No problem here

Then I run the container using

kiyauden@kiyauden-pc:~/Docker/SeedBox$ docker run --cap-add=NET_ADMIN --cap-add=NET_RAW -it seedbox 

But when i try to login to nordvpn this appends

root@3e8a64e5d874:/app# nordvpn login
It seems there's an issue. Please check your internet connection and try again.

My guess is there is a problem with networking

So i mailed NordVpn support and the response was to run the following commands :

sudo iptables -F INPUT
sudo iptables -F OUTPUT
sudo iptables -P INPUT ACCEPT
sudo iptables -P OUTPUT ACCEPT
sudo systemctl restart NetworkManager <-- I can't seem to make this one work

I still get the same error.

I’m stuck here, I need your help :grinning: