Docker Community Forums

Share and learn in the Docker community.

Issue with special characters (accented characters and such as ç) on built ubuntu/debian images

Hello, beforehand, I’ve tried many google solutions landing at this forum, stackoverflow, ask ubuntu, brazilian websites, blogs for most of the day (it’s 17h:09 right now) and nothing. Please refrain from unhelpeful answers, if this is the incorrect place, please point me to the right one.

  • I have 2 images, ubuntu:18.04 and debian:latest that will run python API.
  • I’m running these images from windows machine.
  • I build the container with a docker file as stack deploy (swarm)
  • tried setting the locale (command line bellow) as: en_US.utf-8, en_CA.utf-8, pt_BR.utf-8, pt_br.ISO8859-1, installing locales-all and so many others.

What happens is that:

  • I can’t see special characters on terminal (such as “à” “é” “î” “Õ” “ç”);
  • neither type them with my keyboard (nor using altGr)
  • neither inside python, stabilishing encoding utf_8 or latin1 see these characters. If I set to pt_BR locale, the characters doesn’t show. For canadian show me as “???” and others as coombination of characters (/32/&2 …).

I’m really inclined on this is a docker issue because inside a virtual machine (VMware and virtualbox) and even a laptop directly installed with ubuntu doesn’t have these issues.

Any help is appreciated.