Docker Community Forums

Share and learn in the Docker community.

Kitematic CLI not configured to show my containers/images on Mac - invalid bind address format

beta

(Vatervonacht) #1

Hello,

I am using docker Version 1.12.1-rc1-beta23 (build: 11375) on a Mac running El Capitan. Also using Kitematic(beta) 0.12.0. Kitematic generally works just fine. However, when I open the CLI (whale button on bottom left) the shell is not properly configured (DOCKER_* variables not set). I run ‘eval $(docker-machine env)’ to set the environment, then when I try running ‘docker ps’ I get the following:

‘Invalid bind address format: “tcp://<my_host_ip_address>:2376”’

Also, PRIOR to running ‘$(docker-machine env)’, ‘docker ps’ shows no running containers - even though they show as running in Kitematic. When I run ‘docker ps -a’, I see four old images that I created previously - however these old images do not show up in Kitematic. I’m a bit confused at this point.

Is this a bug, or a misconfiguration on my part?

Thanks,
T.