Docker Community Forums

Share and learn in the Docker community.

Kitematic won't launch unless I run as administrator


(Snuggle) #1

I get the following error message when I try to run Kitematic on Windows 10 without running it as administrator:

Docker Machine is not installed. Please install it via the Docker Toolbox.

It works fine if I “run as administrator” though.

Please help me to run it under my standard account if possible. Thanks.


(Vberruchon) #2

I got the same problem under Windows 7 and it’s quite a problem in a big organisation where not everybody will have administrator rights.
Is there some configuration files or means that could help to launche Kitematic with a standard account?


#3

I’ve had the same issue: I could start the vm and containers via Docker Quickstart Terminal, but with Kitematic the error you described occured.

I solved this problem by inspecting the environment variables for Windows. For the admin user, the Docker Toolbox Path (C:\Program Files\Docker Toolbox) was registered for Path and for a variable called DOCKER_TOOLBOX_INSTALL_PATH.

So I created a new entry for the current user (DOCKER_TOOLBOX_INSTALL_PATH = C:\Program Files\Docker Toolbox) and it worked :slightly_smiling: