Docker Community Forums

Share and learn in the Docker community.

Kubernetes upgrade plans


#1

Please could someone comment on any plans to upgrade the version of Kubernetes provided by Docker for Mac.

Some of us use Docker for Mac to work with Knative and when Knative upgrades to 1.11 or later, we won’t be able to user Docker for Mac unless it upgrades Kubernetes.


(Jgielstra) #2

Yea I’ve had to switch minikube and it isn’t nearly as friendly to use with proxies, mounts, docker-env…


#3

+1.

Kubernetes 1.10.3 is vulnerable to CVE-2018-1002105, and needs a security update ASAP.