[macOS] Disk image location not working


I have installed Docker Desktop 4.20.1 (110738) on my MacBook Air M1, 2020 running macOS 13.4.

Under SettingsResourcesAdvanced, I changed the Disk image location to my external SSD drive. After clicking on Apply & restart, all I get is the spinning blue “circle”. It has been doing this for more than 40 minutes now.

Any ideas?

Edit: Also, the selected folder on the SSD drive remains empty except for the created DockerDesktop folder that also remains empty

I don’t know the solution, but I tried to change the location now and I got the same result, although I didn’t wait for 40 minutes. My guess was Docker Desktop copied the data slowly so I copied the disk image manually in the automatically created “DockerDesktop” folder but that didn’t work, because the “DockerDesktop” folder was not empty. When I tried to set DockerDesktop as destination, it just created a new DockerDesktop folder inside it.

Fortunately when stopped Docker Desktop and started it again, it used the original folder so I didn’t break my environment.

My other guess was that macOS needs permission to write your SSD, but I used another folder my user’s home so it couldn’t be the problem for me and I couldn’t find any indication of copying in the logs.

tail -f "$HOME/Library/Containers/com.docker.docker/Data/log/host"/* | grep -i copy

The above command will give you warnings because there are directories there not just regular files, but I tried this to search for possible indications in all the log files. If you check the files sorted by time

cd "$HOME/Library/Containers/com.docker.docker/Data/log/host"
ls -latr 

You will find log files changing because the host can’t reach the virtual machine which is not running, but I still couldn’t find out what was happening. Then I tried to search among the open issues and find it

You can read the suggestions there and comment to share your experience.


I found this topic which is very similar to this issue except that is related to Windows: