Unable to move the disk image location

Hi there,

I’m unable to move the location of the disk image to an external drive in the resource page. The path update however each time I quit the page and go back then the path path has reset to the previous locateion. Yes, I do an apply. Teh reason I want to move the image to an external drive is to make it bigger.

I’m running:
Mac OS Sonoma 14.4.1
Docker Desktop 4.28.0

Anyone has an idea?


You can join the conversation here:

I don’t know why this issue comes back from time to time. I don’t need to change the disk image location, but when I tried many versions before to test it for someone, the same happened as now. It doesn’t really change the location so I don’t think it gos back when you restart. It probably never changes the location. An empty folder is created. MAybe something happens in the background which I can’t see.

But this is a comment that seemed to help people:


Moving to my preferred location and then adjusting it in /Users/[user]/Library/Group Containers/group.com.docker/settings.json worked for me :slight_smile:

Hi rimelek,

I followed the instructions (resizing to smaller size while setting the external drive) and it did work. Thanks for the link.