Disk Image Location is not possible!!

Please, urgently need your help!
I am using Docker v.4.22.0 on iMac along with WebODM.
I want to change the disk image location to save space.
If I do this in Settings/Resources it works.
But the next time I start Docker, the default disk image llocation is up to date again!!
I’ve tried everything! What can I do to make my change persist after restarting Docker?
Thank you very much!

1 Like

I’m having the same problem with 4.22.0 on a MacBook Pro. I changed the directory to an external drive and built multiple images last week before quitting Docker Desktop. Today, the location has reset to its default and the setting cannot be reset to the external location because the DockerDesktop directory already exists in that location. Of course it does, as does the large VM file I would rather not have to recreate each time I start the application.

I’m having the same problem

I remember when I tried it last time just to test it, it coudln’t save the new location. Now it does, but nothing is moved to the new location. I guess nothing was really changed and only the UI showed the new location so when I started Docker Desktop again, it read the configuration where it was still the old location.

You could open an issue here: