Docker Community Forums

Share and learn in the Docker community.

Missing server.pem file while booting up docker host on vsphere using machine


(Preetip) #1

Hi

I have installed docker-machine(Docker version 1.8.2, build 0a8c2e3) on Ubuntu trusty
docker-machine version 0.4.0 (9d0dc7a)
I am getting following error
open /root/.docker/machine/machines/dockervm0/server.pem: no such file or directory
I deleted the prevoiusly created vm and created a new vm but still getting the same error.
Not abel to ssh in vm getting exit status 255. I have created another docker vm but this also has the same error.
Following command also fails: docker-machine regenerate-certs. Not sure what is the issue .


(Ranjandas) #2

Hi,

Can you get the contents of the directory /root/.docker/machine/machines/<machinename>

Regards


(Preetip) #3

Hi

Following is the content of the /root/.docker/machine/machines/
boot2docker.iso ca.pem config.json id_rsa id_rsa.pub userdata.tar

ca.pem file was not present in this folder. I copied it from the /root/.docker/machine/certs folder .

Regards


(Preetip) #4

Do I need to change the docker-machine version or is there something else missing ?


(Nicholas Dille) #5

Hi,

have you resolved the issue? A solution would be very welcome because I am seeing the same issue here.

I am running docker machine 0.7.0 on Windows Server 2016 TP5 and server.pem is not created. On Linux, this works without manual intervention.

Thanks for your help.
Nicholas