MobyLinux.ps1 created using CmdletBindings instead of default

Hi Im trying to setup Docker Desktop to use Linux Containers, Im running into a issue because when first learning how to do this, not fully understanding what docker machine was, I followed these instructions and in the process deleted my MobyLinuxVM. Now I am unable to get Linux containers to run. I have tried uninstalling and installing docker desktop again but noticed from comparing my MobyLinux.ps1 script to a teammates that docker desktop, when installing, creates the MobyLinux.ps1 file on the fly. Mine is now using CmdletBinding’s and is binding to a old machine i created and deleted. My question is does anyone know how to reset whatever configs the installer is looking at in order to have the MobyLinux script created correctly?

So it turns out my previous assumptions were totally wrong. The installer is not looking any configs or cached information anywhere to build the MobyLinux.ps1 script. It just so happens that in the newest versions of docker, 2.1.* from what i can tell, they renamed the VM from MobyLinuxVM to DockerDesktopVM, which just so happened to be the name of the first docker-machine i created when following the tutorial. So I thought the installer was trying install itself based on the machine I had running. This is not the case. I was able to get Docker Desktop running by simply rolling back to where the MobyLinux.ps1 was now referencing MobyLinuxVM instead of DockerDesktopVM. Still no fix for versions 2.1 and up tho.