Docker Community Forums

Share and learn in the Docker community.

Beginner question: Container should always run

Hello,

after many hours of investigation and try-and-error, I finally have to ask the community.

I am an absolute beginner, so please apoligize if my question seems dumb.

We have a Win 2016 server and have to run 4 containers on it. We already got the containers as tar file with install instructions.
The containers were build on a Linux based Docker installation on Windows.

Just for testing, I run the common nginx Container on Port 80, which works perfectly. (docker run -d -p 80:80 nginx)
After I logout of the server, the web site is no longer reachable.
When I log in again, I can see the container with “docker ps”, but it is still not working. I have to restart docker and re-create the container.
Since this is a server application, which has to run for ever, this behaviour is not good at all.

I already tried out the EE version. But this was awkward to configure and I never got it managed.
So uninstalled EE and installed Desktop Version again.

Then I saw, that my colleague did not have the Whale in the Taskbar. As he started Docker himself, he got the message, that some other instance is already running.

So at that time I realized, that this Docker installation is User-based - could that be?

How can I simply create a Windows Server with running Docker containers in the background, which always respond, independent from a user login?
This is a basic server task, Docker somehow can do this, I am sure…

Greetings, xola

Hi

Im not a big windows expert, but it seems like you dont need the docker desktop app for windows server 2016+.
Have you checked this: https://docs.docker.com/install/windows/docker-ee/ ?

Sure, I checked this but could not get it working - no Hyper-V Machine was created and it simply did not work
Maybe you could help me out?

Since I have to run a Linux Container, I need a Linux Hyper-V machine. With docker-machine I created one named “MobyLinuxVM” just like I was used to, but still I get curious error messages when pulling/running containers.

One error was, that it could not start the VM (don’t know exactly the wording)…