Docker Community Forums

Share and learn in the Docker community.

'MobyLinuxVM' failed to start. 'MobyLinuxVM' failed to initialize


(Mike O'Grady) #1

Expected behavior

Successful installation of Docker for Windows

Actual behavior

unable to get basic installation completed with beta7

Information

Steps to reproduce the behavior

(all started with a Wireless Connection)

  1. This laptop started as a Windows 7 that was upgraded to Windows 10 Pro to accommodate requirements for Docker for Windows.
  2. Hyper-V role is not included as part of the Windows 7–> Windows 10 upgrade. I had removed VirtualBox before the upgrade but had not removed VMware Workstation 9.
  3. Download of Docker for Windows and installation proceed as one would think. Installation of Docker for Windows realizes that HyperV role does NOT exist and solicits a response to install HyperV.
  4. HyperV role gets added which requires a restart of laptop.
  5. Role is successfully added but Docker For Windows fails with ERROR: ‘MobyLinuxVM’ failed to start. ‘MobyLinuxVM’ failed to initialize.
  6. HyperV Manager was inspected and DockerNAT switch is connected to internal network.
  7. Removed all components (HyperV role, Docker For Windows) and restarted.
  8. Reinstall with same result
  9. Repeat removal process and this time I remove VMware Workstation 9.
  10. Reinstall with same results for MobyLinuxVM
  11. Try to change DockerNAT switch to connect to wireless adapter.
  12. Same result
  13. removed Docker For Windows and HyperV again
  14. connected laptop via hardwired connection — wireless device if now turned off.
  15. complete repeat of the above process and still unable to start MobyLinuxVM

Had to change the execution policy of the laptop to get .\DockerDebugInfo.ps1 to run. I am unaware of what would be the appropriate information to include to minimize privacy concerns. I have the output available if needed and if you could suggest what somewhat sanitized approach might be.

Suggestion: I might have compromised the entire process by having VMworkstation installed ahead of the Docker For Windows installation process. I seemed like it added the HyperV role successfully via your installation process but when I tried to install the role myself — it indicated that I had to remove Workstation. The same might be true for Parallels or other virtualization technologies. Probably want to guard against all things that can conflict/compromise a successful HyperV role addition for you installation process.


(Vincent De Smet) #2

can you make sure the DockerNAT internall swich is removed and see if there is any NetNat object with the “10.0.75.0/24” subnet - if so, run Remove-NetNat <name-of-object>. Then try to use the “Reset” function to recreate everything.

Once the reset finishes, ensure the Virtual Interface linked to the Virtual “DockerNAT” switch (usually called vEthernet(DockerNAT)) has been assigned the static ip “10.0.75.1”. I found those were the issues I had and I manually re-created everything to fix it.

Also, while doing the installation process, monitor the logs with the following command for troubleshooting:

gc $(gi -Path $env:LocalAppData\Docker\* | Sort-Object LastAccessTime -Descending | Select-Object -First 1) -Wait

(Mike O'Grady) #3

Thanks for the assistance thus far.

I wasn’t able to have any success and I must admit that I don’t understand the details behind "Remove-NetNet " as I can’t discern how to find

I have accepted the latest update to the beta and it didn’t resolve my problem either.

I uninstalled Docker4Windows, I uninstalled HyperV and let the system restart.

I then installed the latest download for the beta which in turn wants to make sure that the HyperV role is enabled and usable so I let that take place as well.

I now see this in the install procedure indicating the inability to create the “DockerNat” switch because of a conflict. Log enclosed. Any idea how I remove that conflict?

[13:19:39.708][Program ][Info ] Version: Version 1.11.0-beta8 (build: 1832)
[13:19:39.724][Program ][Info ] Starting on: 4/23/2016 1:19:39 PM
[13:19:39.724][Program ][Info ] Resources: C:\Program Files\Docker\Docker\Resources
[13:19:39.724][Program ][Info ] OS: Windows 10 Pro
[13:19:39.724][Program ][Info ] Edition: Professional
[13:19:39.740][Program ][Info ] Id: 1511
[13:19:39.740][Program ][Info ] Build: 10586
[13:19:39.740][Program ][Info ] BuildLabName: 10586.212.amd64fre.th2_release_sec.160328-1908
[13:19:39.740][Program ][Info ] Id: 4ebd02fb-3043-4b50-abdf-4164bae585ae
[13:19:39.755][Program ][Info ] Sha1: d26fe3c627354b5c3205d6ef8a0918c60af6751e
[13:19:39.755][Program ][Info ] You can send feedback, including this log file, at https://forums.docker.com/c/docker-for-windows
[13:19:39.802][HyperV ][Info ] Checking for Hyper-V Windows optional feature
[13:19:39.818][PowerShell ][Info ] Run script…
[13:19:41.393][HyperV ][Info ] Hyper-V Windows feature is enabled
[13:19:42.065][Authentication ][Info ] Checking token
[13:19:42.471][Authentication ][Info ] Token is valid
[13:19:42.471][Auth ][Info ] null credential
[13:19:42.487][Auth ][Info ] Invalid credentials retrieved
[13:19:42.503][Firewall ][Info ] Closing ports on the firewall…
[13:19:42.503][PowerShell ][Info ] Run script…
[13:19:42.893][Updater ][Info ] Checking for updates on the Beta channel…
[13:19:43.206][Updater ][Info ] Found remote version. Version = 1.11.0.1832
[13:19:43.206][Updater ][Info ] Local version is up to date.
[13:19:43.221][Updater ][Info ] Check for update done.
[13:19:46.784][PowerShell ][Info ] Run script…
[13:19:48.190][Firewall ][Info ] Ports closed
[13:19:48.206][Firewall ][Info ] Opening TCP ports on the firewall for C:\Program Files\Docker\Docker\Resources\com.docker.proxy.exe…
[13:19:48.206][PowerShell ][Info ] Run script…
[13:19:49.675][Firewall ][Info ] Ports opened
[13:19:49.690][Firewall ][Info ] Opening UDP ports on the firewall for C:\Program Files\Docker\Docker\Resources\com.docker.proxy.exe…
[13:19:49.690][PowerShell ][Info ] Run script…
[13:19:51.081][Firewall ][Info ] Ports opened
[13:19:51.081][HyperV ][Info ] Creating a virtual machine named MobyLinuxVM
[13:19:51.081][HyperV ][Info ] Checking for Hyper-V Windows optional feature
[13:19:51.096][PowerShell ][Info ] Run script…
[13:19:51.987][HyperV ][Info ] Hyper-V Windows feature is enabled
[13:19:52.003][PowerShell ][Info ] Run script with parameters: -Create True -IsoFile C:\Program Files\Docker\Docker\Resources\mobylinux.iso…
[13:19:56.378][HyperV ][Info ] Enabled workaround for Build 10586 VMSwitch issue
[13:20:02.768][HyperV ][Info ] Creating Switch: DockerNAT…
[13:20:04.643][Notifications ][Error ] Error: Failed to create Switch “DockerNAT”: Instance MSFT_NetIPAddress already exists


(Luis Alberto Gonzalez Ascencio) #4

Hey, I have that same issue Oscar Romero a coworker help me to understand how “Hiper-V” works, find the Admin app, next, clic in your user name, and you’ll be able to see the machine “MobyLinuxVM” try to start it, when I try it send me an error that I don’t have enought memory, next, I go to Configuration and change the size from 2 GB to 1 GB, save the changes and try again, I restart my computer after this steps and Docker works as well, enjoy!
Here you can find some documentation about my Docker experience: https://goo.gl/r0A5S9
And this is the file with some screnshoots about the Issue Related: https://goo.gl/Y2Tbiv