'MobyLinuxVM' failed to start

Same exact error here. Verified hypervisor is supported and running (I have no problem running VirtualBox VMs). Running windows 10. Diagnostic ID: 8B24A7C1-4D38-4EB4-97E1-1DF3FEBFDD34/2016-06-14_22-17-00

This is also happening to me after the latest Windows update.

Same error here - started after Windows Update KB3163018.

I had the same issue. I uninstalled the KB3163018, reboot and then did a factory reset and now it’s working fine.

1 Like

The problem persists after upgrading to Beta 16 (same error log).

So this has been going on for a week then and no feedback from Docker.
Has anybody been able to get this working at all?

Edit: After restarting Windows, it worked perfectly for me. At least for now.

Tried restarting and made sure bcdedit shows “hypervisorlaunchtype Auto”.

Still have the error

For some reason, it started working again for me today as well.

At first when I got to work, there was an error about Docker trying to create DockerNAT (which failed, since it already exists).

After doing a restart of Docker, it started working again. No amount of rebooting or resetting helped before the weekend. Weird.

Edit: And now it isn’t working again. Now with the previous error again "Virtual machine ‘MobyLinuxVM’ could not be started because the hypervisor is not running "

I have a system with the KB3163018 update and Beta16 and it worked fine.

Could I suggested to disable Hyper-V, reboot, enabled Hyper-V and reboot and try the Beta16 again as it seems that the update may have screwed the Hyper-V installation on some system.


1 Like

I give up, back to mac

No luck - tried installing beta16, then disabling hyper-v, shutting down, restarting, enabling hyper-v, shut down, restart. Same error.

Tried uninstalling KB3163018 - same error.

Tried uninstalling and re-installing docker for windows - same error (pasted below).

Latest diagnostic is: 8B24A7C1-4D38-4EB4-97E1-1DF3FEBFDD34/2016-06-22_08-14-36

[Notifications ][Error ] Failed to start VM “MobyLinuxVM”: ‘MobyLinuxVM’ failed to start.

Virtual machine ‘MobyLinuxVM’ could not be started because the hypervisor is not running.

‘MobyLinuxVM’ failed to start. (Virtual machine ID 7E0F49E9-C9EE-46E1-8C81-E889F032CCF7)

Virtual machine ‘MobyLinuxVM’ could not be started because the hypervisor is not running (Virtual machine ID 7E0F49E9-C9EE-46E1-8C81-E889F032CCF7).

The following actions may help you resolve the problem:

  1. Verify that the processor of the physical computer has a supported version of hardware-assisted virtualization.

  2. Verify that hardware-assisted virtualization and hardware-assisted data execution protection are enabled in the BIOS of the physical computer. (If you edit the BIOS to enable either setting, you must turn off the power to the physical computer and then turn it back on. Resetting the physical computer is not sufficient.)

  3. If you have made changes to the Boot Configuration Data store, review these changes to ensure that the hypervisor is configured to launch automatically.

Tried all of these steps Rolf, and it still isn’t working.

Not sure if it matters, but this fails only on my MacBook Pro (running Windows). It’s working fine on my other desktop Windows.

I opened a PowerShell prompt as Administrator and entered the following command.

bcdedit /set hypervisorlaunchtype Auto

After restarting Windows I was finally able to launch Docker successfully.


This is exactly what is happening to me, on my MacBook Pro running Parallels 11 (Windows 10 Insider latest) it never starts, and if it does I get it for 1 time, and then any sleep function will essentially render the MobyLinuxVM useless, and I need to completely start from scratch by reinstalling Hyper-V & Docker for Windows.

But on my other desktop which is running Windows 10 Insider latest build 14672 it runs perfectly…

It’s always a bit of an issue when you try to do virtualization shenanigans inside of an already virtualized machine. I’m guessing because the emulated hardware isn’t doing 100% what the underlying host’s hardware would do.
So it’s probably best to use Windows machines, if possible, instead of Windows on Mac.

I installed docker two days back, first run after installation was proper. But once I restart my system I am not able to run. Here is the Id of diagnostic logs - FAE270D4-A99D-4F78-A2CE-C2680EDD38C5/2016-06-28_11-56-40. Now it is showing an error like failed to change state.

Ah, we had issues with bootcamp disabling the virtualisation extensions in the BIOS and it seems it is a common problem. Apparently booting into OS-X and then doing a soft-reboot into windows works. See for example:
http://www.codeadventures.com/use-hyper-v-in-bootcamp/ and http://apple.stackexchange.com/questions/120361/how-to-turn-on-hardware-virtualization-on-late-2013-macbook-pro-for-windows-8-1

1 Like

That actually worked! Awesome!

Had to reset Docker to factory defaults, but it’s definitely working now. Thanks!

1 Like

I still ave the problem with my windows 10. what is the resolution here?

Hi ,

I am trying to install docker on my windows10 pro guest operating system but it is giving error one of the hyperv component is not running . Need urgent help