Docker Community Forums

Share and learn in the Docker community.

Networking issues

Hello Docker-Community,

I am a software developer and my goal is to run docker on a local windows machine. As Operation System I am using Windows 10 Pro. We do have a repository which is using the ip 172.17.123.45.Our companies LAN is using the IP Range 172.16/16. By default, docker is using the same range (172.16/16) so i changed it to 172.18/16 using the bip parameter. Everything should work like a charm with this settings. I also tried using 192.168.200.0/16 but this resulted in not beeing able to pull images from our registry (host not found).

I’m currently using: Version (1.13.0-beta38 (9805) 9c31a15) and everything seems to work perfectly.
One of my colleagues is using 1.12.0-stable (build:5968) 9cd1dc2 and everything works.
3 other colleagues are using: Version 1.13.0 (9795) 0c6d765.
But one of them is getting a host not found error. when trying to login.

is there any way to debug this?

Could you colleague upgrade by any chance? If not, please have him run diagnostics and open an issue here: https://github.com/docker/for-win/issues/new

The one with “no host” problem is one of the 1.13.0 (9795) 0c6d765. should he switch to beta?

It would definitely be interesting to learn whether that solves the problem.

Well he simply reinstalled docker - problem solved!