Docker Community Forums

Share and learn in the Docker community.

[SOLVED] "docker-machine ip" does not work on my Windows 10 Pro

docker

(Dockergi) #1

I changed PC because my previous computer was too slow.
I installed Windows 10 Pro 64bit and updated everything on new hardware.
Later I installed “Docker for Windows Installer.exe”.
Finally I opened the Windows command prompt and created my image and its container. It seems that everything went well but when I type “docker-machine ip” to find the IP to which my container is listening I get this error message:

“Error: No machine name (s) specified and no” default “machine exists”

I’m sure it’s not a Docker problem or a problem of my code because everything worked perfectly on the previous PC.
How do I solve?
Thank you

docker version
Client: Docker Engine - Community
 Version:           18.09.2
 API version:       1.39
 Go version:        go1.10.8
 Git commit:        6247962
 Built:             Sun Feb 10 04:12:31 2019
 OS/Arch:           windows/amd64
 Experimental:      false

Server: Docker Engine - Community
 Engine:
  Version:          18.09.2
  API version:      1.39 (minimum version 1.12)
  Go version:       go1.10.6
  Git commit:       6247962
  Built:            Sun Feb 10 04:13:06 2019
  OS/Arch:          linux/amd64
  Experimental:     false

Do I have to install the Docker Toolbox?
Do I need to install Kitematic-Windows?
Do I have Virtualbox installed on Windows?
Do I have to have a specific version of Virtualbox?
Why Kinematic-Windows does not install?


[SOLVED] Error: No machine name(s) specified and no “default” machine exists
Running Docker and VirtualBox on the same machine
(Dockergi) #2

Why nobody answers me? has the docker support for windows 10 been deleted?
Can I have any sign of your presence?

Thank you


(Dockergi) #3

Why nobody answers me?


(Dockergi) #4

I tried to watch this video:


I can tell you with absolute certainty that “Docker Quickstart Terminal” does not provide the IP.

[SOLVED] Why does nobody respond to my messages?
(Dockergi) #5

Maybe I solved it by myself. I will continue to test docker in the coming days. Maybe I even found the bug.