Docker Community Forums

Share and learn in the Docker community.

NFS volume sharing works on my Mac, but not my co-worker's Mac

I am following this great blog post on Docker OS X with NFS.

I got everything working perfectly on my Mac.

When I went to roll it out to the next guy on our team, he is able to stand up our environment, and the volume gets mounted properly with no errors when running docker-compose -up, the shared /Projects directory is there, but nothing works - when trying to identify why, when we docker exec -it /bin/bash container the /Projects directory is giving this:

$ ls -la /Projects
ls: cannot open directory '.': Stale file handle

We tried everything - including completely reinstalling Docker for Mac, and rebuilding every image from scratch, to no avail. On his Mac:

d?????????  ? ?  ?    ?      ? Projects

On my Mac, doing everything the exact same way

drwxr-xr-x 31 501 dialout 992 Apr 7 19:55 Projects

The frustrating thing is I ran into none of these issues on my machine, and by all accounts they are identical Macs with identical configs, bought within 3 months of each other, both running Mac OS Catalina 10.15.3 (19D76) and the latest Docker for Mac, 2.2.0.5 (43884).

Here is the bug report.