Docker Community Forums

Share and learn in the Docker community.

Partition /mnt/wsl/docker-desktop-data/isocache filling up to 100%

Hi All, today has been my second time to encounter a strange thing:

My containers couldn’t startup or show the error message ‘no space on device left’ during startup after my Windows 10 had done an Update and Restart by itself in the night and i had to startup my whole system again (development sytem for multiple Websites on my working computer).

After some intense research i could pinpoint the problem down to the isocache mount from the “docker desktop for windows”, which is at 100% usage. Last time i could overcome it so far by increasing the max. size of the vhdx for this mount ( C:\Users******\AppData\Local\Docker\wsl\data\ext4.vhdx ) from 200GB to 500GB - but that can’t be the real solution.
I already tried to optimize it (after shutting down docker and WSL) with the command “Optimize-VHD -mode full ext4.vhdx” - but no change.

root@*******:~# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sdb 251G 197G 42G 83% /
tmpfs 13G 252M 13G 2% /mnt/wsl
tools 1.9T 873G 989G 47% /init
none 13G 0 13G 0% /dev
none 13G 8.0K 13G 1% /run
none 13G 0 13G 0% /run/lock
none 13G 0 13G 0% /run/shm
none 13G 0 13G 0% /run/user
tmpfs 13G 0 13G 0% /sys/fs/cgroup
C:\ 1.9T 873G 989G 47% /mnt/c
D:\ 100M 33M 68M 33% /mnt/d
M:\ 451G 315G 137G 70% /mnt/m
N:\ 16G 7.6G 7.8G 50% /mnt/n
/dev/sdd 480G 464G 0 100% /mnt/wsl/docker-desktop-data/isocache
none 13G 12K 13G 1% /mnt/wsl/docker-desktop/shared-sockets/host-services
/dev/sdc 251G 119M 239G 1% /mnt/wsl/docker-desktop/docker-desktop-proxy
/dev/loop0 369M 369M 0 100% /mnt/wsl/docker-desktop/cli-tools
tmpfs 13G 412K 13G 1% /mnt/wsl/docker-desktop-data/tarcache/entries/docker.tar/362570e871de9b43d12fa4022ac7e29989099f93ed53945fbf060222d501e6e9/containers/services/docker/tmp
overlay 13G 412K 13G 1% /mnt/wsl/docker-desktop-data/tarcache/entries/docker.tar/362570e871de9b43d12fa4022ac7e29989099f93ed53945fbf060222d501e6e9/containers/services/docker/rootfs

But the content of that mount is just 3GB?!?!?

root@*******:~# du -sh /mnt/wsl/docker-desktop-data/isocache
3.0G /mnt/wsl/docker-desktop-data/isocache

My system info:

Windows 10 Professionell 64-bit
Version 2004 (Build 19041.685)
Intel i7-7700
32GB RAM

Docker Desktop community
Version 2.5.0.1 (49550)
Engine: 19.03.13
Compose: 1.27.4
Kubernetes: v1.19.3
Notary: 0.6.1
Credential Helper: 0.6.3
Snyk: v1.424.4

Use the WSL2 based engine

Using WSL2-Linux-Distribution “Ubuntu 20.04”

1 Like

Same here, solved with:
docker builder prune

which removes the build cache.

That command didn’t change anything on my system, still 100% usage. I had “reinstalled” my docker for windows by deleting the “ext4.vhdx” file and could work again - just lost all my container - but yesterday it happened again, during developing one of my web applications (not building any image)?!?!?!?!?!?

I’m experiencing the same issue. Has anyone solved it?

$ df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sdc        251G  2.4G  236G   1% /
tmpfs            25G  401M   25G   2% /mnt/wsl
/dev/sdb        251G  251G     0 100% /mnt/wsl/docker-desktop-data/isocache
none             25G   12K   25G   1% /mnt/wsl/docker-desktop/shared-sockets/host-services
/dev/sda        251G  130M  239G   1% /mnt/wsl/docker-desktop/docker-desktop-proxy
/dev/loop0      397M  397M     0 100% /mnt/wsl/docker-desktop/cli-tools
tools           260G   87G  174G  34% /init
none             25G     0   25G   0% /dev
none             25G  8.0K   25G   1% /run
none             25G     0   25G   0% /run/lock
none             25G     0   25G   0% /run/shm
none             25G     0   25G   0% /run/user
tmpfs            25G     0   25G   0% /sys/fs/cgroup
C:\             260G   87G  174G  34% /mnt/c
D:\              11T  1.6T  9.4T  15% /mnt/d
$ du -sh /mnt/wsl/docker-desktop-data/isocache
2.6G    /mnt/wsl/docker-desktop-data/isocache

Hi, i found something interesting recently:

It seams that inside this virtual partition are also some or all partitions of the running containers hidden. Found this when i had restarted docker and accidently checked the partitions usage at that time. I have stopped one container that i use nearly at no time from my DEV-Setup currently, and since then that partition is at snails speed going to fill up now instead of just a few weeks.