Docker Community Forums

Share and learn in the Docker community.

Not able to run Docker Quickstart Terminal (VirtualBox bug)

docker
build

(I2connector) #1

I have installed the Docker for Windows 10. but I am not able to run the Docker. please let me know is there anything I am missing here.

Starting “default”…
(default) Check network to re-create if needed…
(default) Windows might ask for the permission to create a network adapter. Sometimes, such confirmation window is minimized in the taskbar.
(default) Creating a new host-only adapter produced an error: C:\Program Files\Oracle\VirtualBox\VBoxManage.exe hostonlyif create failed:
(default) 0%…
(default) Progress state: E_INVALIDARG
(default) VBoxManage.exe: error: Failed to create the host-only adapter
(default) VBoxManage.exe: error: Assertion failed: [!aInterfaceName.isEmpty()] at ‘F:\tinderbox\win-5.1\src\VBox\Main\src-server\HostNetworkInterfaceImpl.cpp’ (74) in long __cdecl HostNetworkInterface::init(class com::Bstr,class com::Bstr,class com::Guid,enum __MIDL___MIDL_itf_VirtualBox_0000_0000_0038).
(default) VBoxManage.exe: error: Please contact the product vendor!
(default) VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface
(default) VBoxManage.exe: error: Context: “enum RTEXITCODE __cdecl handleCreate(struct HandlerArg *)” at line 94 of file VBoxManageHostonly.cpp
(default)
(default) This is a known VirtualBox bug. Let’s try to recover anyway…
Error setting up host only network on machine start: The host-only adapter we just created is not visible. This is a well known VirtualBox bug. You might want to uninstall it and reinstall at least version 5.0.12 that is is supposed to fix this issue
Looks like something went wrong in step ´Checking status on default´… Press any key to continue…


(Michael Friis) #2

It looks like you’re using Docker Toolbox - I recommend just using Docker for Windows: https://docs.docker.com/docker-for-windows/install/


(Jama12) #3

I’m actually having the exact same issue with Docker Toolbox. I’m using Windows 10 home, and receive the exact same error. I’ve uninstalled VirtualBox and reinstalled version 5.1.24, but no luck.

According to the documentation, Docker for Windows needs Windows 10 Pro or better; Windows 10 Home will not work. Anyone have suggestions on how to resolve this error with Docker Toolbox?


(Rmuellerjr03) #4

I’m in the same boat (Windows 10 Home) with the same error. Any help regarding the VirtualBox bug would be great.


(Bobspeck) #5

I ran into the same issue trying to install Docker Toolbox on to Windows 8.1 64 bit. I resolved the problem by uninstalling the Oracle VirtualBox, then reinstalling, this time selecting the NDIS5 driver instead of the the default NDIS6 driver. No issues after that.