Odoo Localhost:8069 issues with ssl and reverse proxy

Hi I posted this in the Oddoo forum but didn;t get much help. Am hoping someone here can comment.

I have two issues that are causing me grief. Am running Odoo 16 Community in a docker environment with nginx on Ubuntu 20.04.

  1. The generated sitemap has addresses using localhost:8069 instead of my domain name like:

http://localhost:8069/website/info

2 - I have installed Paypal module to handle website payments and everything works except the return address from paypal also has localhost:8069 as the address, despite me manually putting a return address in my Paypal account setup.

I have set the system parameter web.base.url to my domain name and added the freeze parameter, this has had no effect on either issue.

From searching the only thing I think it could be is there is something wrong with the reverse proxy setup in nginx, though my gut says both these problems are coming from Odoo not the web server. The actual reverse proxy is working fine to access the site over ssll. Here is my odoo.conf file:

Anything wrong here?
For for the sitemap I have tried deleting the sitemap-1.xml attachment, it always regenerates a new sitemap, still with the localhost addresses!

Any help would be appreciated!

Thanks,

Mark

I would think this has to be changed in the Odoo settings. Similar Wordpress saves the first domain you install it to, it will always redirect to it, unless you change it in the internal settings.

I tend to agree with you. Must be internal to Odoo. Can’t find where for the life of me though!