Docker Community Forums

Share and learn in the Docker community.

Parallels Desktop The VM couldn't get an IP address after 60 tries


(Toastmastersdocker) #1

Expected behavior

MobyLinuxVM starts

Actual behavior

Failed to start VM “MobyLinuxVM”

Information

  • the output of:
    Failed to start VM “MobyLinuxVM”: The VM couldn’t get an IP address after 60 tries
    at Docker.Core.Pipe.NamedPipeClient.TrySend(String action, Object[] parameters)
    at Docker.Core.Pipe.NamedPipeClient.Send(String action, Object[] parameters)
    at Docker.Core.Backend.BackendClient.Start(Settings settings)
    at Docker.Actions.<>c__DisplayClass26_0.b__0()
    at Docker.Core.TaskQueue.<.ctor>b__16_0()

  • Docker Log: https://gist.github.com/anonymous/98a0477ab02033b34705f60ee98703e4

  • Docker version: 1.12.0

  • Parallels Desktop version 11.2.1

  • Host OS: Mac OS X

  • VM for Parallels Desktop: Windows 10

I’m using the default network settings inside docker (10.0.75.0, 255.255.255.0, Auto DNS) and I get the issue above. I’ve tried using the beta build of docker but that produces the same issue. I’ve also tried clean installs of both versions of docker followed by machine restarts. Under Windows Network Connections, I noticed there are two Ethernet connections, one that PD creates and one that Docker creates vEthernet. The default ethernet from PD is connected but the other says Unidentified Network. I have no VPN software running. What other suggestions may I pursue to try and resolve this issue?

I feel like this is more to do with PD than Windows at this point, perhaps there is a configuration step I’m missing in PD? Does anyone use Docker inside PD and can guide me in the right direction?

Steps to reproduce the behavior

  1. Launch Parallels Desktop Windows 10 VM.
  2. Docker auto starts and fails.

(Gporcelli) #2

I am experiencing your same problem, have you solved out ?