Docker Community Forums

Share and learn in the Docker community.

Problem running wsl_update_arm64.msi

I’m installing a new amd-based mobo – have enabled Hyper-V in bios and Windows Features look correct. When I attempt to run ‘wsl_update_arm64’ (as per link show via Docker’s WSL 2 installing is incomplete dialog) I’m getting ‘This installation package is not supported by this processor type.

I’m pretty sure I’m up to date re: framework and whatnot:

Edition Windows 10 Pro
Version 21H1
Installed on ‎1/‎1/‎2020
OS build 19043.1052
Experience Windows Feature Experience Pack 120.2212.2020.0

What else can I try? thx!

The msi package for the arm64 architecture is not designed for your amd-based system (which requires a package for the amd64 or x86_64 architecture) .

I assume you created the post by accedent in the “Docker Desktop for Mac” subforum, even though it is about Windows?

Yeesh – 2 strikes in one thread. Sry 'bout that. All’s well here now. thx