Pulling Docker images: i/o timeout

Having the same issue. Docker pull works on 1.09 but times out on 1.11

In my case, running docker run hello-world caused error dial tcp: i/o timeout.

The following repaired the issue for me on Mac OS X El Capitan. Went to System Preferences > Network > Advanced > DNS and added DNS server After that, I restarted Docker for Mac and ran docker run hello-world successfully.

Some Windows users have encountered the same issue and managed to get it working in a same way. See: https://docs.docker.com/docker-for-windows/troubleshoot/#networking-issues

1 Like

I got the same issue on centos 6.8 - Docker 1.7 . Could you please advise where can I change the DNS ?


Got the same issue. Fixed it instantly by restarting my internet connection…

This might not be the most subtle solution but dropping the docker VM and recreating it solved it for me

And I have taken depo …haha so sad every link I have visited , and the problem only comes about when installing erpnext , other thing hav gone well

Thanks David docker-machine restart vm worked for me.

I faced the same issue while pulling image from java 8. Restarting Docker Machine Solved the problem.
error pulling image configuration: Get https://production.cloudflare.docker.com/registry-v2/docker/registry/v2/blobs/sha256/d2/d23bdf5b1b1b1afce5f1d0fd33e7ed8afbc084b594b9ccf742a5b27080d8a4a8/data?verify=1622389727-JAFN7iPhthbGx4nA4LClUVudCTo%3D: dial tcp i/o timeout

Solution: Restarting the Docker Machine