Docker Community Forums

Share and learn in the Docker community.

Docker pull timeout

docker
beta

(Buzzalderaan) #1

Expected behavior

Pull a docker container.

Actual behavior

Successfully pull a docker container. This works without issue on installations on other Mac OX machines.

e.g.
docker pull memcached
Using default tag: latest
Pulling repository docker.io/library/memcached
Network timed out while trying to connect to https://index.docker.io/v1/repositories/library/memcached/images. You may want to check your internet connection or if you are behind a proxy.

Information

pinata diagnose -u
OS X: version 10.11.5 (build: 15F34)
Docker.app: version: v1.11.1-beta14.5.m
Running diagnostic tests:
[OK] docker-cli
[OK] Moby booted
[OK] driver.amd64-linux
[OK] vmnetd
[OK] osxfs
[OK] db
[OK] slirp
[OK] menubar
[OK] environment
[OK] Docker
[OK] VT-x
Docker logs are being collected into /tmp/20160608-202004.tar.gz
Most specific failure is: No error was detected
Your unique id is: 90603EDD-424C-453A-BAC8-CDE597236C6B

I have also attempted to fully remove any previous Docker install before upgrading to Docker for Mac beta. As stated above, I have been successfully using Docker for Mac Beta (latest version) on other Mac OS X 10.11.5 machines without issue. The only difference being the machine it isn’t working on is older, but ran Docker without issue.

Steps to reproduce the behavior

  1. install/reinstall/reset factory settings Docker for Mac Beta
  2. attempt to pull an image

(Maksim77) #2

+1
i have the same problem

996B65DB-7938-4640-B634-5AFCE620E973


(PILLAUD TIRARD) #3

I have the same issue and it not solved with the latest version. I did a factory reset without any result… a uninstall and reinstall without any result neither.

Did you someone solved the problem?

Here my docker info:

Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 1.12.0-rc2
Storage Driver: aufs
Root Dir: /var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 0
Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: overlay bridge null host
Swarm: inactive
Runtimes: default
Default Runtime: default
Security Options: seccomp
Kernel Version: 4.4.13-moby
Operating System: Alpine Linux v3.4
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 1.954 GiB
Name: moby
ID: AGCX:KZMJ:XXU3:6HGF:RPRX:3ZNN:OTUT:MDVJ:F7MD:N3WY:VWGX:3MSQ
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): true
File Descriptors: 21
Goroutines: 28
System Time: 2016-06-21T21:51:03.175517554Z
EventsListeners: 1
No Proxy: *.local, 169.254/16
Registry: https://index.docker.io/v1/
Experimental: true
Insecure Registries:
127.0.0.0/8


(Banesto) #4

I have the same issue on Mac 10.11.4 and Docker version 1.12.0-rc2, build 906eacd, experimental.
The weird thing is that it’s working fine when connected to my company’s VPN network.


(Buzzalderaan) #5

I just updated to Docker for Mac Version 1.12.0-rc2-beta16 (build: 9493) and I am now able to successfully pull images to my heart’s content.


(Banesto) #6

I still have the same version and problem still persists :frowning:


(Scflode) #7

I also have this issue with 1.12.0-rc2-beta16 (build: 9493) on a Mac Mini late 2012. Just installed Docker for Mac today. On all other Macs it works without issue.


(Vkat) #8

What @banesto said, works when I connect to my company’s VPN.


(Njbarrett) #9

I have the same issue:
$ docker run hello-world Unable to find image 'hello-world:latest' locally Pulling repository docker.io/library/hello-world docker: Network timed out while trying to connect to https://index.docker.io/v1/repositories/library/hello-world/images. You may want to check your internet connection or if you are behind a proxy.. See 'docker run --help'.

Diagnostics:
Docker for Mac: version: mac-v1.12.0-beta16.2
OS X: version 10.11.4 (build: 15E65)
logs: /tmp/20160628-102126.tar.gz
failure: No error was detected
[OK] docker-cli
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux


(Villuppi) #10

I had this same issue with beta. It seems that when you have corporate dns first on your osx dns list that docker only uses it. If your first dns server isn’t reachable and fails Docker doesn’t trye next name server in list. This is odd because all other apps on osx works greate! Docker’s vms dns points directly to host ip but something after that goes wrong.

Related to:


(Banesto) #11

That could be the case, but I tried the same Docker verions on another computer which do not have VPN installed and it still had the same error, I ended up installing company VPN in order to get it working. :frowning:


(Scflode) #12

That solved my issue as the primary DNS was not reachable at that time. Thanks for the hint!


(Wilcobou) #13

Solved my issue too, seems that my IPv6 DNS server wasn’t reachable, changing the order in the network settings made the problem go away.


(Xavijs) #14

You saved my docker! :slight_smile:


(Ldcasillas) #15

I just experienced this problem and, following an idea in this comment from another thread, I worked around the timeout issues by disconnecting my ethernet cable and using only the WiFi. (Unlike the commenter in that thread, both interfaces were on when I was having trouble.)


(Mayerwin) #16

Still same issue with the latest version on Windows…


(Mayerwin) #17

Update: Got it working with pure default Docker configuration (no manual DNS set to 8.8.8.8, no IP V6 deactivation), by removing Unlocator-related settings from the router (its specific DNS server, and maybe more problematic, static routes that redirected 8.8.8.8 and 8.8.4.4 to the router itself as recommended to get Chromecast working)! I had to reboot the router afterwards and disable/re-enable local network adapters. Strange that Docker is the only application which encountered issues because of this set-up.


(Jhampson) #18

I am experiencing the same problem posted a thread related to it here


(Banesto) #19

This issue is resolved for Mac in Release 1.12.0-rc4-beta20! Thanks guys!


(Wunch) #20

I did some testing, and I wouldn’t really call this completely fixed. Yes, docker will now check the secondary DNS server in the list if the first one does not respond, but it does not seem to continue any further than that, which is an incomplete solution IMO.

For me, my non-work DNS was fourth in the list. Docker (beta21) continued to network time out unless I dragged that server to be either first or second in the list.