Pushing first time to hub via docker desktop, access denied

Hi all

it is the first time I am trying to push an image to the hub.
I do it via docker desktop.
I am logged in, I verified several times via the browser.
When I click push to hub I get denied:requested access to the resource denied

I also created a private empty repository but it does not show up in the desktop app.

I spent a lot of time on this and am quite lost now. Any help is greatly appreciated.

Do you care to share some actually details or was your intent just sharing the error message with us?

i am new to this, I do not know of any additional details. I provided all the information that I have. I followed the instructions and I see this message. I think dockerhub is not for me. thanks and sorry for bothering.

There is no need to be sorry. It’s all good.

Though, without knowing what you tried and how you tried it, how should we recommend what needs to be done different?

Update: the very crucial word “no” was missing in the first sentence. … now I am the one being sorry (blush)

What is the tag (name) of the image?

What is the name of that repository?

I guess you named it like “myimage” and think that it will be pushed to your private repository because you are logged in, but that is not the case. The name of the image have to contain the name of your repository like:


and optionally a version tag