Docker Community Forums

Share and learn in the Docker community.

Reason to get "Object not found" from BuildHistory API of DockerHub

I would like to know any reason why I get “{"detail": "Object not found"}” status from the API, even there’s an already built image?

I linked the account with GitHub and whenever I push any changes to GitHub repo, the auto-build on Docker Hub reacts and builds the image. So it seems that automated build is working.

Also, I notice that searching the docker repo with $ docker search coreos-transpiler, I get NOT “[OK]” on “AUTOMATED” column.

I need to fix this in order to place a build status badge via shields.IO (https://shields.io/category/build) on my GitHub repo.

Below are the samples which return any info:

  • https://hub.docker.com/v2/repositories/cpuguy83/ubuntu/buildhistory/
  • https://hub.docker.com/v2/repositories/cubeearth/tools-coreos-ct/buildhistory/
    • Docker Build Status
1 Like

I thought that the lack of “automated tests” (https://docs.docker.com/docker-hub/builds/automated-testing/) caused the problem.

But even adding and passing the automated test, the “build history” API still gives me “{"detail": "Object not found"}” response.

Seems that not having the “[OK]” status at “AUTOMATED” column in “docker search [OPTIONS] TERM” results, has something to do with the problem.

Maybe I have to “docker push” the version tagged image rather than having only the “latest” in “tags” tab.

  • Related topic: “AUTOMATED not show ‘OK’ after successful automated build”
    • https://forums.docker.com/t/automated-not-show-ok-after-successful-automated-build/69505
  • Related article: “The misunderstood Docker tag: latest”
    • https://medium.com/@mccode/the-misunderstood-docker-tag-latest-af3babfd6375 @ Medium

Did you eventually get this working? I have the same problem

2 Likes

@sune

Did you eventually get this working?

Unfortunately, no. :sob:

I still get no “[OK]” on docker search results, nor get any “buildhistory” info from the API rather than “Object not found”. No docs too.

My guess is that:

(1) The current “automated build” process run on “Docker Cloud” (https://cloud.docker.com/)
(2) Then pushes the built image to “Docker Hub”(https://hub.docker.com/).
(3) Since it’s not built on Docker Hub but on Docker Cloud, Docker Hub API doesn’t contain a “buildhistory”.

I noticed it by pointing the shields.IO badge from “Docker Build Status:” to “Docker Cloud Build Status:” and got the right status.

  • Docker Build Status: Docker Automated build

  • Docker Cloud Build Status: Docker Cloud Build Status

I haven’t tried but by pushing the locally built image to Docker Hub using docker CLI command might work.

But if that’s the case, I wonder why they call it Automated.