Docker Desktop Stopped

Hi,

It seems that my Docker app occasionally stoped working and outputs the error “Docker Desktop stopped…”. I think this may be happening whenever my computers screensaver kicks in. Here is a screen recording of the issue: Dropbox - File Deleted

If I click restart docker then I get the following error:

supervising tasks: task com.docker.vpnkit with pid: 93718 failed
failed to run backend processes

1 Like

Im having this exact issue. Happens one every other day. Have you tried turning of the experimental features?

I have not. How do I do that and does that help?

Its under “features in development” under settings, but I haven’t tried it yet. Also checkout this issue - which is similar to this. It suggest downgrading to 4.12

Since the video is not available now, may I ask on what operating system Docker Desktop is running? It is supported on Windows, macOS and Linux, so it could be important and I am sure Docker Hub has nothing to do with the issue, although it is the category you have chosen.

macOS but I solved the issue by downgrading to version 4.12 so it seems to be something with the latest update.

I’ve been having problems with the docker daemon becoming unresponsive for a few months. The Docker Desktop menu icon is animated as if it is trying to restart. I select it, choose “Restart”, and after a few minutes I’m back in business.

But these last few days it’s been happening several times a day. Today it finally stopped restarting successfully. I reluctantly opted to reset factory defaults, but this didn’t help. I re-downloaded the image and tried again, but it won’t even start. The welcome screen flashes for a split-second and disappears.

My macOS console log reports the following:

Process:               Docker [62266]
Path:                  /Applications/Docker.app/Contents/MacOS/Docker
Identifier:            com.docker.docker
Version:               4.14.1 (91661)
Code Type:             ARM-64 (Native)
Parent Process:        launchd [1]
User ID:               502

Date/Time:             2023-01-09 16:46:50.0200 -0800
OS Version:            macOS 12.6.2 (21G320)
Report Version:        12

Is there some part of Docker Desktop that I can remove so that a re-install can start successfully?

I talked about it on YouTube: Uninstalling Docker Desktop properly on macOS - YouTube

In the video I just show some ways to find out what you can remove, but different Docker Desktop versions can have different files and if you have Docker extensions installed, it could be important to delete the folders of those too. Be careful! Remove files that you are sure would not break something else on your Mac.

I also experienced some issues when I started Docker Desktop some months ago, but the latest Docker Desktop on the latest macOS (Ventura 13.1) looks stable on my MacBook.

1 Like

Thank you, Ákos. This helped me a lot. Not only was I able to get Docker Desktop working again, but my containers were intact, some of which would have taken me a while to reconstruct.

The part of your video that helped the most was using grep to identify the outstanding docker processes. I ran kill -9 on everything except com.docker.vmnetd. From there, I was able to restart Docker Desktop successfully with my containers intact.

I wonder, if in my case, one of the processes didn’t shutdown properly and was holding onto a mutex that was required by the Docker Desktop to start the daemon properly.