Docker Community Forums

Share and learn in the Docker community.

Running docker-compose on existing compose configuration results in an error


(Jpatters) #1

Expected behavior

docker-compose should work as per usual

Actual behavior

running docker-compose results in the following error

ERROR: TLS configuration is invalid - make sure your DOCKER_TLS_VERIFY and DOCKER_CERT_PATH are set correctly.
You might need to run `eval "$(docker-machine env default)"`

Information

OS X: version 10.11.4 (build: 15E65)
Docker.app: version v1.11.1-beta12
Running diagnostic tests:
[OK] Moby booted
[OK] driver.amd64-linux
[OK] vmnetd
[OK] osxfs
[OK] db
[OK] slirp
[OK] menubar
[OK] environment
[OK] Docker
[OK] VT-x
Docker logs are being collected into /tmp/20160522-085449.tar.gz
Most specific failure is: No error was detected

The contents of docker-compose.yml and Dockerfile don’t seem to matter

Steps to reproduce the behavior

  1. Create a docker-compose.yml with docker toolbox and get it up and running.
  2. Install Docker for Mac and use the migration tool
  3. Once Docker for Mac is up and running, run docker-compose on the same configuration file in the same directory.

All I had to do to fix this was copy the contents of the entire folder to a new folder and it suddenly worked in the new folder while running it in the old folder still doesn’t work.
I will continue testing this and update with more info.