Docker-compose & TLS

Hey, I’m trying to use docker-compose with the new Beta but get the following:

ERROR: TLS configuration is invalid - make sure your DOCKER_TLS_VERIFY and DOCKER_CERT_PATH are set correctly.
You might need to run eval "$(docker-machine env default)"

Any ideas?

Having the same problem. Did you find a solution?

For me the problem was that docker and docker-compose weren’t appropriately symlinked to the docker mac versions (see this bug that I just created: Docker and docker-compose didn’t symlink correctly). This fixed it for me:

rm /usr/local/bin/docker
rm /user/local/bin/docker-compose
ln -s /Applications/ /usr/local/bin/docker
ln -s /Applications/ /usr/local/bin/docker-compose

I am having this same issue. @adamgotterer s solution did not work. I’ve completely uninstall docker toolbox, reinstalled Docker 4 Mac, tried creating a ca, cert, and key in ~/.docker but nothing is working.

1 Like

Same issue :confused:

Do you still have any DOCKER_* in your env?

something like “env | grep DOCKER” should yield an empty result.

1 Like

This was my issue, thanks.