Docker Community Forums

Share and learn in the Docker community.

[SOLVED] Failed to start VM 'MobyLinuxVM'


(Elishnevsky) #1

Hello,

I have installed the latest Docker for Windows, Hyper-V, restarted the computer and Docker fails to start VM "MobyLinux.VM. The exact error in the log is the following.

Attachment ‘C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\MobyLinuxVM.vhdx’ could not be found due to error: ‘The system cannot find the file specified.’

And that’s right, this file doesn’t exist. I don’t know why. Is there any way to re-create it?

Thanks!


(Rolf Neugebauer) #2

Hi @elishnevsky

could you try and re-installing Docker for Windows, ie un-install and then install again? We do test the scenario on fresh installs with Hyper-V disabled and have never seen this issue.

Thanks
Rolf


(Elishnevsky) #3

Hi, Rolf

I have reinstalled Docker and got the same problem. I have uploaded the entire log file: log-2016-06-03_11-43-05.txt (10.4 KB)

Hopefully it will help resolve the problem.

Thank you,
Eugene.


(Elishnevsky) #4

I solved the problem! I opened Hyper-V Manager and saw MobyLinuxVM listed there, but there was no physical file. So I deleted it from the list and restarted Docker. And voila! It’s working now.


(Rolf Neugebauer) #5

Hi @elishnevsky

glad you fixed it and thanks for the log file. Something odd happened on your system. The install only seem to have half finished…hmmm

I also recommend updating to Beta14 (released yesterday). it fixes another issue I saw in your logs (DHCP server related). You can update by enabling auto-update.

rolf