Docker Community Forums

Share and learn in the Docker community.

[solved] Mounted Windows Volume is not getting any data


(Archergod) #1

Expected behavior

I have Beta for Windows installed, I create a gitlab-ce Container using kinematic and it works well. Then in kinematic I mount my windows volume to 3 volume expose by gitlab container. But when I am creating Project in gitlab it is not creating those files in my windows mounted volume.

Actual behavior

When I create new project, or gitlab’s log should come to mounted windows volume but they are not coming, In kinematic I can see they are send to same path that I mount to.

Steps to reproduce the behavior

I am using Docker Beta for Windows, I got invite few days back. Gitlab-CE is the latest today.

Sorry I am new to docker and doesn’t fully understand the working of it, I just install from invite and trying out it for first time.


(Michael Friis) #2

Have you enabled drive sharing in settings? Details here: https://beta.docker.com/docs/windows/troubleshoot/#host-filesystem-sharing:71d91e3b9a3ad860ebd774a04de7b4a4


(Archergod) #3

Hello, Yes I have that option checked. After I check that then only kinematic allow me to select a proper folder.

Also, it gives error if I do not select folder within User’s Home folder i.e. C:\User\username\xxx folder. ( I want to move it out of user folder as my user folder is on SSD which is near full )


(Archergod) #4

Okay, I get it to working, I recheck my settings, “unchecked” C: and then re-check it and then reboot my gitlab did the trick.

Also, I was able to mode data from my C: by simply making a symoblic linked folder (mklink /j ) so my actual folder is on other drive but in docker I put path like C:\User\username\dockerfolder. and it works,

really enjoying the new docker, It enable me to install and run Gitlab on Windows 10 :slight_smile: … just need to find how to start container at start up, doesn’t find an option in container settings. But that is another ticket I don’t found it. For now thanks for your help.