Docker Community Forums

Share and learn in the Docker community.

SSH logon impossible after fresh Docker for azure deploy


(Incahuazi) #1

Hello,

I’ve spent the whole day on this so any help would be greatly appreciated.

I followed the install guidelines for docker for azure (https://docs.docker.com/docker-for-azure/) and installed the docker CE stable channel successfully on azure.

Next step is trying to connect to the manager node using following command

ssh -i “E:\temp\DockerKeys\private.ppk” -p 50000 docker@51.144.118.xxx

but this always fails with following error.

Unable to negotiate with 51.144.118.xxx port 50000: no matching host key type found. Their offer: ssh-rsa,rsa-sha2-512,rsa-sha2-256

I generated the public/private key pair using putty key generator and entered the public key in the deploy template.

The type of key is SSH2 RSA. I also tried to use SSH1, but this fails on deployment (The value of parameter linuxConfiguration.ssh.publicKeys.keyData is invalid.)
I tried with a shorter SSH2 RSA key of 512 but get the same error.

Steps to reproduce the behavior

  1. Launch https://portal.azure.com/#create/Microsoft.Template/uri/https%3A%2F%2Fdownload.docker.com%2Fazure%2Fstable%2FDocker.tmpl

  2. Generate public private key using putty key generator and use the public key + other parameters as input for the template.

  3. Find the public ip of the manager node and try to connect using the private key

Thanks in advance for any help.