Struggle with 'Get started with docker'

Hi folks,

i’m new to Docker and i’m still walking through the ‘Get Started’ article. So far, Docker for Windows is installed and Kubernetes is running. At the point to enable Docker swarm i ran into some issues because Docker asked some unexpected questions to me.

I execute the command ‘docker swarm init’ and i receive following:

Reading the CLI reference shows up the opportunity to bind an adapter. So i ran this command:

“docker swarm init --advertise-addr WLAN”

Running the command ‘docker service create --name demo alpine:3.5 ping 8.8.8.8’ as a test afterwards, it says: “1/1 no suitable node (unsupported platform on 1 node)”

What is this meant to be? Any suggestions?

Greetings from Germany
Chris

Is it safe to asume that “WLAN” actualy is a placeholder for the ip of the network adapter? Make sure to use a fixed ip. Swarm doesn’t realy like it, if the ip of nodes change…

Seems like your installation is switched to run Windows containers, see: Redirecting…

Your command should work like this: docker service create --name demo --platform linux alpine:3.5 ping 8.8.8.8, see https://blogs.msdn.microsoft.com/appconsult/2018/09/20/running-containers-based-on-different-platforms-side-by-side-with-docker-preview/

Hello Metin,

thanks for your reply. Please let me answer your question.

‘WLAN’ isn’t a placeholder. It’s the name of my WiFi adapter in Windows. Ah ok, using DHCP is the reason for this … :smiley:

Regarding to Windows and Linux containers. As a default the linux containers are used. What can be a reason to use Windows containers?

Greets,
Christian