Docker Community Forums

Share and learn in the Docker community.

TLS-daemon error for Docker client 1.7.1 on CentOS 7

docker

(Dfresh4130) #1

I have a new VM running CentOS 7 and I’ve installed docker, but am running into the common “trying to connect to a TLS-enabled daemon without TLS” error. Works fine with sudo so I’m not sure what I’m missing. The docker group didn’t exist after installing it so I tried adding it, but that made no difference. Service is running and restarted multiple times too. I’ve seen other posts talking about running boot2docker, but that’s not installed on my system. Any suggestions?

[centos@test ~]$ cat /etc/redhat-release
CentOS Linux release 7.1.1503 (Core)

[centos@test ~]$ sudo service docker stop
Redirecting to /bin/systemctl stop  docker.service
[centos@test ~]$ sudo service docker start
Redirecting to /bin/systemctl start  docker.service
[centos@test ~]$ ps -ef | grep docker | grep -v grep
root     19072     1  2 17:42 ?        00:00:00 /usr/bin/docker -d -D --selinux-enabled
[centos@test ~]$ groups centos
centos : centos adm wheel systemd-journal dockerroot docker

[centos@test ~]$ docker version
Client version: 1.7.1
Client API version: 1.19
Package Version (client): docker-1.7.1-115.el7.x86_64
Go version (client): go1.4.2
Git commit (client): 446ad9b/1.7.1
OS/Arch (client): linux/amd64
Get http:///var/run/docker.sock/v1.19/version: dial unix /var/run/docker.sock: permission denied. Are you trying to connect to a TLS-enabled daemon without TLS?

[centos@test ~]$ sudo docker version
Client version: 1.7.1
Client API version: 1.19
Package Version (client): docker-1.7.1-115.el7.x86_64
Go version (client): go1.4.2
Git commit (client): 446ad9b/1.7.1
OS/Arch (client): linux/amd64
Server version: 1.7.1
Server API version: 1.19
Package Version (server): docker-1.7.1-115.el7.x86_64
Go version (server): go1.4.2
Git commit (server): 446ad9b/1.7.1
OS/Arch (server): linux/amd64

(Dfresh4130) #2

Looks like the issue was I just needed to logout and back in so the group permissions would take effect properly.