Docker Community Forums

Share and learn in the Docker community.

Unable to install docker on mac os x yosemite (10.10.5)


(Ankit105) #1

Expected behavior

Docker.app should install

Actual behavior

Get this message when I double-click on Docker.app:

You need administrator privileges on this computer to install Docker. Please log in as an administrator to install the app, then you can use Docker with standard user accounts.

Cannot even execute the ‘pinata’ command below.

Information

  • the output of:
    • pinata diagnose -u on OSX
    • DockerDebugInfo.ps1 using Powershell on Windows
  • a reproducible case if this is a bug, Dockerfiles FTW
  • page URL if this is a docs issue or the name of a man page
  • host distribution and version ( OSX 10.10.x, OSX 10.11.x, Windows, etc )

Steps to reproduce the behavior

  1. …Download docker for mac from https://beta.docker.com/docs/
  2. …Open the docker.dmg and drag it to Applications folder
  3. …Double click the Docker.app

(Jonahwh) #3

I have the same exact issue. The only unusual thing about my environment is that this is a network account, and a Mobile account.


(Ankit105) #4

I was finally able to fix this issue. I tried following two things that appeared to have worked:

  1. I had admin, managed and mobile account privileges on my mac similar to yours. I also had parental controls checkbox enabled (i dont know why…:)) under System Preferences -> users and groups. I created another admin account and switched user to the new account. Then, I unchecked parental control checkbox, restarted and logged in as myself.

  2. I upgraded OS to OSX El Capitan 10.11.5. But that didn’t help. After some research I found that EL Capitan comes with built in System Integration Protection feature which is enabled by default. I had to disable it. More on how to do this is on this here:
    http://www.macworld.com/article/2986118/security/how-to-modify-system-integrity-protection-in-el-capitan.html

Hope this helps :slight_smile:


(Jonahwh) #5

I didn’t have parental controls on, and disabling SIP didn’t work.

I ended up just creating a temporary Admin user, and opened the Docker app there. Now it works fine.