Unable to login into forums.docker.com

Whenever I open forums.docker.com and I click “Login”, it tries to login with the incorrect google account. There is no way to choose the account I have linked already. I tried clearing cookies of this forum and from google but still showing the same. The “correct” account is logged in with google and the “incorrect” one is logged out.

Any of the following solutions may be good:

  • enable choosing which google account to use to login
  • add a way to switch to user/password (because if it detects a google account, it won’t show user/password screen)
  • choose the google account which is logged in

I’m afraid you’ll need to raise an issue at https://github.com/docker/hub-feedback/. This forum is not frequently visited by Docker staff.

Considering how long I am here and on Docker Hub, if it turns out it is an existing feature, it may be a strange question from me, but how do you even connect your Google account to the forum? I have a linked social account on the Kubernetes forum, but I don’t know any way to link an account on the Docker forum. I had to use my Docker ID to log in.

Docker Hub supports linked accounts, but not for authentication, only for auto build.

1 Like

Ah, maybe my first response, which I edited in the grace period hence does not show in any edit history, applies after all. Something like:

Are you sure you’re using Google to log in? Are you sure it’s not just the Chrome browser in which you’re authenticated with Google, and then the browser suggesting some saved credentials for this forum? When trying to register a new account today (with Firefox), I do not get any option to use third party logins; I only get to choose a username (Docker ID) and password. Care to share some screenshots (without any personal details) so we can understand the flow you’re seeing?

But then I noticed the following detail in the question, which made me disregard the above:


I guess it detects Docker Hub account, which works similar to Google authentications. When you are authenticated in Docker Hub and click on the Login button on the forum, you don’t need to authenticate again. It will let you in.

Ah, maybe that’s what is happening?

I read this as somehow only a Google-specific login option is shown (instead of username/password), not as already being authenticated and being allowed in without any prompt at all. :thinking: Screenshots to the rescue please! (Or, @lepe, if you’re sure it’s about a Google login, then an issue in GitHub, which may need some screenshots too.)

It seems its not related to google but to hub.docker.com. Because I had my other google account logged in with hub.docker.com (but not associated yet in this forum) it shows an “Authorize App” screen (so I got confused :upside_down_face:).

Once I logged out from “hub” and logged in with the correct account all works fine. Mystery solved.

This was the screen I’m talking about: