Unable to open Docker Desktop because of automatic WSL update

I am very new to Docker and have been trying to implement it where I work because it would make hosting some of our application way easier. I work on a network that has blocked access to the Windows Store and Windows Update is managed by group policy. When I try to launch Docker Desktop it prompts me to pick Recommended Settings or Use Advanced Settings. No matter what I select, Docker tries to run an update on WSL and it fails (because it is blocked) and then Docker quits. I have manually updated wsl with it’s msi file and it is completely up to date. Is there ANY way to turn off the automatic update check that Docker Desktop does when it is launched? I tried going into AppData\Roaming\Docker and changing the settings.json file. there is a tag called “wslUpdateRequired” but when I set it to false and then launch docker it gets reset to true.

Yes. Just to be fair, it could make some tasks harder, but it is worth it.

I have to ask though, are you trying to run Docker Desktop to host production containers or is it just a development machine? If the latter, that’s okay, but Docker Desktop is not meant to run as a server in production.

Do you mean it tries even after you updated WSL2 manually? Are you sure it is the right version? I don’t think Docker Desktop would try to update WSL2 when it is a supported version.

Please, share your Docker Desktop version and the version of WSL2.

It’s a development environment. And I’ve tried updating manually using the .msi file located in step 4 on the manual install instructions located here: Manual installation steps for older versions of WSL | Microsoft Learn

If that isn’t the correct way to manually update that could explain it. I am unable to run the wsl --update command because the download sources are blocked for me.

My Docker Desktop Version is 4.28.0
If I run wsl --status I get the below output:

Default Distribution: Ubuntu
Default Version: 2

Windows Subsystem for Linux was last updated on 12/12/2023
The Windows Subsystem for Linux kernel can be manually updated with ‘wsl --update’, but automatic updates cannot occur due to your system settings.
To receive automatic kernel updates, please enable the Windows Update setting: ‘Receive updates for other Microsoft products when you update Windows’.
For more information please visit Manual installation steps for older versions of WSL | Microsoft Learn.

Kernel version: 5.10.16

So I see it hasn’t been updated since I first installed it, so whatever kernel I’m downloading isn’t correct but I’m not sure where to find a newer version. I will mention though I’ve had this issue since my initial install so I would have thought my WSL would have been up to date at that point but I might be misremembering the timeline.

So I went and looked since you helped me realize my WSL version was indeed out of date and found a mirror to download the kernel. After quitting and re-opening Docker Desktop it seems like that may have solved my issue. I’ll keep an eye out to see if it happens again but thanks so much for your help so far.