Unable to open Docker

An unexpected error occurred

Failed to deploy distro docker-desktop to C:\Users\Chirag Nahata\AppData\Local\Docker\wsl\distro: :

Some WSL system related access rights are not set correctly. This sometimes happens after waking the computer or not being connected to your domain/active directory. Please try to reboot the computer. If not sufficient, WSL may need to be reinstalled fully. As a last resort, try to uninstall/reinstall Docker Desktop.

I am unable to install docker. The above is the error message. Please help as soon as possible. Thank You

What have you tried so far? The error message mentions some possible solutions. If you tried those, Which is your WSL and Windows version? Do you have WSL 2 or 1?

windows 10, wsl 2, I tried everything, full reinstalling and etc,

Can you run any WSL distribution?

update:

Is your user an administrator? If it is not, you need to add the user to the “docker-users” group.
Were you able to start the desktop before it almost immediately crashed or it is not started at all?