Unexpected WSL error - completely fails to work - re-install doesn't help

I installed Docker Desktop for the first time 3 days ago. It worked for about 2 days. I was able to build images and push them to Docker Hub. Yesterday I woke up my laptop from sleep, and was using it as usual. I opened Docker Desktop, it immediately shows an error poop-up “Unexpected WSL error”. There is more text there, it doesn’t let me copy it. I tried rebooting, then tried re-installing Docker Desktop. Nothing has fixed this so far. It seems to be completely unusable. Any assistance would really be appreciated!

The error message says common causes include access rights issues, which occur right after waking the computer. Well, it did occur right after I woke up. But even a re-install did not fix it. Also, it is quite normal to put laptops to sleep and wake them so. The pop-up suggests re-install WSL which seems quite extreme, almost like just re-install Windows. Surely there is some simple way to get this to work.

1 Like