Unable to pull ubuntu image - Always getting Manifest not found error

I’ve always been able to run this without an issue:

docker pull ubuntu:20.04

Today I’m getting this error for any of the ubuntu tags ans a few other images as well.

Trying to pull repository docker.io/library/ubuntu ...
manifest for docker.io/ubuntu:20.04 not found

I’m using the docker client on Red Hat Enterprise Linux 7 (version Docker version 1.13.1, build 7d71120/1.13.1). It’s the base version that comes with RHEL and is supported by Red Hat. It has always worked before.

Is there a known issue with Docker Hub’s repository?

A docker login did not solve the issue.

Hi @ygirouardstm ,

have you tried

docker pull  --platform linux/x86_64/v8 ubuntu:20.04


export DOCKER_DEFAULT_PLATFORM=linux/x86_64/v8

then do

docker pull ubuntu:20.04

The issue is the version of docker on RHEL7… it’s 1.13.1, but it always worked before. Docker Hub must have changed something. I’m able to pull using a later docker version (although not the one that is supported by Red Hat on RHEL7).

It is not Docker Hub what changed then, but the image formats. I haven’t checked it in this case, but we discussed it recently in other topics. Newer images are often using the new image format and old Docker is not compatible with that. Note that by “newer images” I mean images that were pushed recently even if using the same tag as you pulled before.

Ohhh! That makes sense then. Would explain why some older images still work fine (i.e. httpd).