Docker Community Forums

Share and learn in the Docker community.

Unable to start docker container and run command OCI Runtime Create Failed


(Svenakk) #1

I’m trying to do the following:

Run a specific docker container, lljvm_work. Have it mount a local directory (…/services/c with its docker mirror in c_files). Run a command there (lljvm_cc) to process some files.

What I try to do is:

“docker run -v /home/sven/git/cerberos/CerberOS/uJ/services/c/:/c_files -tid lljvm_work llvjm_cc /c_files/test_c_srv.c -lc_support -o test_c_srv -g3”
Unfortunately, this gives an error as follows:

docker: Error response from daemon: OCI runtime create failed: Container_linux.go:348: starting container process caused “exec: “lljvm-cc”::executable file not found in $PATH”: unknown

I’ve tried putting the command in quotes and such but cannot get it to work. Any advice?

Addendum:
What I’ve also tried is the following
"docker run -v /home/sven/git/cerberos/CerberOS/uJ/services/c/:/c_files -w /c_files -it lljvm_work /bin/bash -c ‘lljvm-cc test_c_srv.c -l_c_support -o test_c_srv -g3’
/bin/bash: lljvm-cc: command not found
"

Which, as you can see, does not work as well. This is on Ubuntu.

Doing these steps seperately, with an interactive shell as follows, does work.
E.g.:

    ~$ docker run -v /home/sven/git/cerberos/CerberOS/uJ/services/c/:/c_files -w /c_files -it lljvm_work /bin/bash

//Container started

root@6a70a2346951:/c_files# lljvm-cc test_c_srv.c -l_c_support -o test_c_srv -g3

// Desired output is created