Docker Community Forums

Share and learn in the Docker community.

Unknown option: n

docker

(Icummings) #1

I tried to remove all instances of docker in order to complete a clean re-install but now I get a "Unknown option: n"
when I run docker Quickstart Terminal. And [docker ps] or [docker images] prints the following to the console: “Cannot connect to the Docker daemon. Is the docker daemon running on this host?”

Any ideas?

Danke.


(Astro03) #2

I get this same error… When clicking “Docker Quickstart” from the Launchpad, I get the following output.

              ## ## ##        ==
           ## ## ## ## ##    ===
       /"""""""""""""""""\___/ ===
  ~~~ {~~ ~~~~ ~~~ ~~~~ ~~~ ~ /  ===- ~~~
       \______ o           __/
         \    \         __/
          \____\_______/

docker is configured to use the default machine with IP 192.168.99.100
For help getting started, check out the docs at https://docs.docker.com

Unknown option: n
Usage: head [-options] …
-m use method for the request (default is ‘HEAD’)
-f make request even if head believes method is illegal
-b Use the specified URL as base
-t Set timeout value
-i Set the If-Modified-Since header on the request
-c use this content-type for POST, PUT, CHECKIN
-a Use text mode for content I/O
-p use this as a proxy
-P don’t load proxy settings from environment
-H send this HTTP header (you can specify several)

-u            Display method and URL before any response
-U            Display request headers (implies -u)
-s            Display response status code
-S            Display response status chain
-e            Display response headers
-d            Do not display content
-o <format>   Process HTML content in various ways

-v            Show program version
-h            Print this message

-x            Extra debugging output

/Applications/Docker/Docker Quickstart Terminal.app/Contents/Resources/Scripts/start.sh: line 68: : command not found


(Nathan Le Claire) #3

Can you file an issue at https://github.com/docker/toolbox including the full output of the Quickstart please? Thanks


(Astro03) #4

I finally resolved this error.

“head” was pointing to a different app then the one in /usr/bin/head


(Anirudh690) #5

Has this issue been fixed ? I am trying to install and it gives me the same error. I downloaded the dmg from the website. What do i need to do to make this work ? Any help.