USB forwarding not working on Windows 10

Hi there, I’m a new Docker user and my goal is to forward USB devices to a container. I’m running Docker using Docker Toolbox on Windows 10 64-Bit Home. I’ve install the VirtualBox extension pack for USB support and enabled the USB controller for the boot2docker VM. I’m trying to launch a ubuntu:16.04 container using --privileged and -v /dev/bus/usb:/dev/bus/usb and I’ve also tried --device=/dev/bus/usb, but I can’t get it working. Regardless of the presence of these flags, lsusb inside the container is showing me two USB hubs that change their description when I switch between USB 2.0 and USB 3.0 in the VirtualBox USB controller configuration - but I don’t see any devices connected to them (tried 3 different USB drives on 3 different ports each). VirtualBox seems to recognize the devices as they are showing up in the filter configuration (I’ve tried both specific filters as well as the full-whitelist filter). dmesg inside the container is not showing any news when I plug/unplug devices. Windows does not mount my USB drives while boot2docker is running. I’m not sure how to debug this situation… Would love to try from within boot2docker whether they are actually available there but I have no clue how to do this. Any help is greatly appreciated!

I’ve managed to resolve this by following the instructions from this post:
The gist of it:

  • Open the Windows registry, by clicking on Start > Run and typing regedit
  • Navigate to the following location HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class{36FC9E60-C465-11CF-8056-444553540000}
  • In the right hand panel, if the the UpperFilters entry exists, then delete it
  • Go to folder C:\Program Files\Oracle\VirtualBox\drivers\USB\filter
  • Click right mouse button on file named VboxUSBMon.inf
  • Click Install