Docker Community Forums

Share and learn in the Docker community.

Uwsgi permission denied

This is so weid… I have a docker image that runs a web app. WHen I run it, nothing shows in containers… no error. Nothing under docker ps -a.

I ran docker events& and tried again, and it reported an error 1… which is apparently an app error, Okay.

So, I re-ran as: docker run -it --entrypoint /bin/bash -p 80:80 --name NAME -d NAME:latest -s

And then ran each item in the runall.sh

The first three items gave a permission denied:
uwsgi --http-socket 127.0.0.1:3009 --file /var/www/cgi-bin/tireorder/main.wsgi --processes 1 --uid root --enable-threads -b 32768 --daemonize /var/www/cgi-bin/tireorder/tireorder.log --pidfile /var/www/cgi-bin/tireorder/tireorder.pid

Looking this up, and it appears to be a user permission, but all the directories and files are full access to root.

What is really freaky is that, I get it to run in windows and a mint linux VM… but in production(RHEL)) or on my linode VMs(Centos 8, Debian 10, Ubuntu 21) is gives the same permission denied!?