Version 4.25.0 broke totally docker engine (and docker itself) on Windows 10

I recently updated docker to 4.25.0 version but it broke my docker engine. In 4.24.2 all worked fine, but now docker engine keeps starting for a huge amount of time, when previously it took only 10 seconds or less, also, it never starts, just says “Docker engine stopped” but I can’t restart it, quit or do anything. I need to force a wsl --shutdown to quit it, but the wsl instance also freezes and I’m not able to shut down it until restart my PC. Also, settings and other tabs are not availeble, they keeps loading. Hope you can help me, and find a solution, for now I’ll uninstall this version and install the previous one.
I’m using Windows 10 Home 64bit and WSL2 with Ubuntu 20

1 Like

I have been havin the same issue and also the “error during connect: this error may indicate that the docker daemon is not running: Get…” when try to started from Power Shell

Maybe they broke something in the new update, the best is wait to future releases and keep in 4.24.2 for now.

I am having issues after updating to the new version as well.

Windows 10, 21H2

In WSL UBUNTU distro, I get:

jweirich@RMT-540665L:~$ jweirich@RMT-540665L:~$ docker run --rm -it --gpus=all nbody -gpu -benchmark
docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.
See 'docker run --help'.

If I run the same command in windows powershell 7.3.7, I get:

docker run --rm -it --gpus=all nbody -gpu -benchmark
Unable to find image '' locally
nbody: Pulling from nvidia/k8s/cuda-sample
22c5ef60a68e: Pull complete
1939e4248814: Pull complete
548afb82c856: Pull complete
a424d45fd86f: Pull complete
207b64ab7ce6: Pull complete
f65423f1b49b: Pull complete
2b60900a3ea5: Pull complete
e9bff09d04df: Pull complete
edc14edf1b04: Pull complete
1f37f461c076: Pull complete
9026fb14bf88: Pull complete
Digest: sha256:59261e419d6d48a772aad5bb213f9f1588fcdb042b115ceb7166c89a51f03363
Status: Downloaded newer image for
docker: Error response from daemon: failed to create task for container: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: error running hook #0: error running hook: exit status 1, stdout: , stderr: Auto-detected mode as 'legacy'
nvidia-container-cli: requirement error: unsatisfied condition: cuda>=11.7, please update your driver to a newer version, or use an earlier cuda container: unknown.

Any attempt to open a devcontainer from my wsl filesystem fails.

Settings for WSL integrations seem correct to me:

Where can I download prior version of docker desktop for windows?

You can find the links here

Thanks, confirmed that downgrading Docker for Windows v4.24.1 fixed my WSL integrations.

Hi there, same issue happened to me yesterday with Docker Desktop 4.25.0 on Windows 11 Pro 22H2.

Cannot connect to the Docker daemon at unix:///var/run/docker.sock.

I had to downgrade to Docker Desktop 4.22.0

Docker Desktop 4.25.0 on Win 11 Home 23H2:
PowerShell: docker run --rm hello-world works as expected
Ubuntu 20.04 with Docker integration sudo docker run --rm hello-world works as well.

It could be that I am “cheating”, because I am using a WSL2 pre-release:

WSLg-Version: 1.0.59
MSRDC-Version: 1.2.4677
Direct3D-Version: 1.611.1-81528511
DXCore-Version: 10.0.25880.1000-230602-1350.main
Windows-Version: 10.0.22631.2506

Yep, 4.25.2 is no better, it is completely unstable. It freezes in the middle of routine ‘compose watch’ updates to an (11) Container web app. Downgrading back to 4.24 which I never had an issue with.

I had 4.25.0 and it stopped working, looked like it was starting, but it wouldn’t work. even after a reboot, still wouldn’t start. I tried upgrading, but now I see that this was a mistake. Everything about Docker Desktop has been a fight for me. I guess I’m going to uninstall and try an older version.