Docker Community Forums

Share and learn in the Docker community.

VMware Workstation 12 Pro / Fedora 30 and Docker 19.03.0-beta4 - Gentoo proxy troubles

docker
beta
#1

Hi all,

Nowthat I managed to get Docker t pull images I thought it might be nice (for internal development purposes) to run Gentoo and play around with a few settings.

However, I run into some issues. Let me provide some details first:

  1. VMware Workstation Pro 12 running Fedora 30 (behind corporate proxy and internet working) - no auth required

  2. Docker details:
    Client: Docker Engine - Community
    Version: 19.03.0-beta4
    API version: 1.40
    Go version: go1.12.4
    Git commit: e4666ebe81
    Built: Tue May 14 12:46:59 2019
    OS/Arch: linux/amd64
    Experimental: false

    Server:
    Engine:
    Version: 19.03.0-beta1
    API version: 1.40 (minimum version 1.12)
    Go version: go1.11.5
    Git commit: 62240a9
    Built: Thu Apr 4 19:17:37 2019
    OS/Arch: linux/amd64
    Experimental: false
    containerd:
    Version: 1.2.4
    GitCommit:
    runc:
    Version: 1.0.0-rc7+dev
    GitCommit: d38f8a2d00ff444e52d16ab1ea5bbe5c1cb471e8
    docker-init:
    Version: 0.18.0
    GitCommit: fec3683

I ran Docker images of Ubuntu (and configured the corporate proxy in Ubuntu as per instructions you find on the internet) and that worked fine.

Now I’m having some more issues on my hands. I pulled gentoo/stage3-amd64 and so far so good. But I’m having issues connecting to the internet. According to the Gentoo handbook, I tried an export http_proxy with the proxy I use for a variety of RHEL, CentOS and Ubuntu Linux distros which can use the proxy and allow me to download, update and upgrade packages.

Gentoo, however, doesn’t seem to like it. I need to download some software and because of the resistance to connect to the internet, I’m stuck right now.

What I want to check

  1. Right now the network seems to be the default bridge network via the docker0 interface. I don’t have reason to believe that this failed as I can use it on configured systems to set up the proxy

  2. Tried to use host network but no luck either

Could someone help me please as I’ve been spending at least 12 hours of troubleshooting but am nonthewiser.

Let me know if you require any more information from my side.