Docker Community Forums

Share and learn in the Docker community.

WatchTower Install Issues

Hello ,
I am running docker on a raspberry pi 4. I am having trouble launching watch tower, idk i am installing it incorrectly. I tried installing it using portainer , pulling and image down and loading that container (i dont know if i need to change some setting in portainer when i build it) and i have also tried to follow these steps. Watchtower both times portainer says its running i cant acess it, Maybe i am using the wrong setting in portainer for the contianer , maybe i am using the wrong port when trying to open it. I have 7 other container installed and running correctly such as , portainer, radarr , sonarr, jackett, sickchill, Ombi, and a Unifi manager. I thought perhaps sickchill and it watchtower was fighting for the same port adress . Rrally i think i might be missing a env variable or the network setting needs to be change, since i think sickchill fights for port 80.

I tried to access it from my local ip 10.0.0.125:( and i tried number ports i thought it was) but no luck, but my other container i can access just that way.

Any help with setting up watchtower would be great! I am computer savy , not docker savy still learning.

Watchtower does not provide a ui. Your expectiation does not allign with how watchtower actually works:
You simply create the container with the arguments you want/need and let it do its job. If you want to know what it did/does, simply check the container logs.

Make sure you understand what watchtowerr does, as some image updates do break compatibility and suddenly you have to troubleshoot and fix things…