When trying to reinstall, getting "The process cannot access the file 'C:\Program Files\Docker\Docker\com.docker.service' because it is being used by another process"

I tried to run it and got errors. So I tried to see if it could be repaired, but no such option. I couldn’t uninstall it. I tried following all instructions and suggestions. There are Ruby and Python installations that apparently conflict. After a pretty thorough cleaning of my Windows installation that I couldn’t uninstall, only a Docker folder remained inside Program Files.

Finally uninstalled and restarted computer. Then I tried once again to do a clean install but I got this error:

Unpacking failed: The process cannot access the file 'C:\Program Files\Docker\Docker\com.docker.service' because it is being used by another process.
   at CommunityInstaller.InstallWorkflow.<DoHandleD4WPackageAsync>d__30.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at CommunityInstaller.InstallWorkflow.<DoProcessAsync>d__23.MoveNext()

The fact that Docker Service remained after uninstalling Docker Desktop confused me, but there it was. There was no Docker app in the Windows Settings Apps & features to uninstall. I’m at a total loss. I don’t know what to do now.

I have NO Docker running. The best I got was an installation that said it was successful & directed me to run Docker Desktop and go to Settings, but I could never get there. It would start up and then just vanish. I’ve got no docker-compose and of course no docker dpkg. I’m dead in the water.

It installed successfully then died. Then I managed to uninstall it, but can’t even install it now. How do I get my Docker back?

Did you try to disable any security (virus scanner) software?

And different errors, but did you try any of the solutions in, e.g,:

I kept doing my own research and finally figured out what was going wrong. I had not activated my BIOS hardware virtualization. that was all I had to do.

It would have helped a lot if I had gotten a message during the installation mentioning that; but no hard feelings. I got it ironed out. Also, people not sure if their computer meets the requirements should also run coreinfo.exe. -v. I chose to run coreinfo64.ext -v since 64 bit is required for Docker. That will save you some time, knowing if your core processor supports SLAT nested paging. That’s quick and easy, though Windows doesn’t have those commands in their System32. I got them from Mark Russinovich’s Sysinternals Suite, which I highly recommend for anyone using Windows. Thanks.

Sorry avbentem, I figured out where to click to reply to you. None of those links were the least bit helpful. I did try all of the supposed “solutions.” None of them were solutions at all, and of course I know that StackOverflow is always our friend and one of the very first sources for help.

Next time please simply provide the details in your first post, and do not expect people to possibly repeat all you may already have tried by just mentioning “I tried following all instructions and suggestions”.

Thanks for posting what worked for you!