Why am I being forced to log in?

I was without an internet connection this morning, and unable to use docker because docker desktop wouldn’t start unless I signed in. I’ve never had this happen before. I’m not part of an organization, there isn’t a registry.json file or otherwise on my machine (unless it’s somewhere not documented). Why is this happening and how do I prevent this in the future?

I don’t know, but I tried and indeed when I log out, it shows “Sign in required”. I couldn’t find anything about it in the release notes or announcements yet. The general FAQ still mentiones Docker Desktop can be installed offline.

https://docs.docker.com/desktop/faqs/general/#can-i-use-docker-desktop-offline

I just tried on DDfW 4.30.0.

As preparation, I signed out in Docker Desktop, pulled the image hello-world and restarted Windows.
Once my Windows user was logged in, I turned off WiFi, and started Docker Desktop (which at this point is not signed in).

It starts without any nag screen/forced sign in. I was even able to start a container in that state:

My Docker Desktop runs with default settings, except: I disabled “Start Docker Desktop when you sign in to your computer”.

After @meyay shared it worked for him, I started to review my settings. It turned out I had “Enable host networking” turned on. It indeed requires signing in. I have no idea why this is the only beta feature that requires authentication, but I disabled it and I could start Docker Desktop without signing in.


.

1 Like

As a workaround, you can disable the feature that requires Docker Desktop to be signed in, by editing the file %APPDATA%\Docker\settings.json.

Search for the line "hostNetworkingEnabled": true, and change it to "hostNetworkingEnabled": false,.
Then save the file and start Docker Desktop.

Since the feature that required the sign in is disabled now, there won’t be a forced sign in.

If anyone tries to find this config on macOS, it is at

$HOME/Library/Group Containers/group.com.docker/settings.json